注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

notes

@-@

 
 
 

日志

 
 
 
 

安装Gebr  

2009-06-02 13:44:56|  分类: UNIX |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

Install guide

There are several ways to install GêBR. The simplest one is adding GêBR repository to your system and let the package manager take care of the rest.

Debian/Ubuntu repository

Follow the four steps below to add GêBR DEB repository to your Debian/Ubuntu machine. Debian users should issue the commands as superuser (root), and Ubuntu users should prefix each command by "sudo".
  1. Add GêBR repository to your list of repositories, by editing the file /etc/apt/sources.list:
    gedit /etc/apt/sources.list

    and add to it the following line:
    deb ftp://ilhagrande.ime.unicamp.br/debian etch contrib

  2. Download and install GêBR repository key:
    wget ftp://ilhagrande.ime.unicamp.br/debian/gebr.key
    apt-key add gebr.key
  3. Update your package list:
    apt-get update
  4. In case you are installing GêBR for first time run:
    apt-get install gebr gebrd debr libgebr0 gebr-menus-su

    To upgrade a previous install run:
    sudo apt-get update
    sudo apt-get upgrade

Fedora repository

As superuser (root), follow the three steps bellow to add GêBR RPM repository to your Fedora machine.
  1. Create the file /etc/yum.repos.d/gebr.repo with the content below:
    [gebr]
    name=GeBR
    failovermethod=priority
    baseurl=ftp://ilhagrande.ime.unicamp.br/fedora
    enabled=1
    gpgcheck=0
  2. Update your package list:
    yum check-update
  3. In case you are installing GêBR for the first time run:
    yum install gebr gebrd debr libgebr

    To upgrade a previous install run:
    yum check-update; yum upgrade

Installing from binary packages

This method should be used in case you did not manage to configure your system to employ the repository.
  1. Download the appropriate package for your system, from download area.
  2. For deb packages run:
    dpkg -i *deb

    For rpm packages run:
    rpm -Uhv *rpm
Despite its simplicity, this method neither allows automatic upgrades upon new releases, nor solve dependency problems.

In case you have a different linux/unix distribution, not base on deb or rpm package format, attempt to install from source codeGêBR has few dependencies, namely:
  • glib 2.8.0 or higher
  • GTK+ 2.8.0 or higher
  • libgdome 0.8.0 or higher
  • libgthread 2.8.0 or higher
  • libgobject 2.8.0 or higher

Note: Seismic Unix user should be aware that installing Seismic Unix menus to GêBR is not enough to have Seismic Unix package, which should be installed itself too.
We provide a package for Debian/Ubuntu (at the repository) users and a script to facilitate this task for Ubuntu users, which could also be employed by Debian users with some tweaks.  Download the gebr-su-install.sh script and follow the steps below:

chmod +x gebr-su-install.sh
./gebr-su-install.sh

  评论这张
 
阅读(535)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018